Autor Tema: Consulta sobre los logs del sistema (RESPONDIDO)  (Leído 61 veces)

0 Usuarios y 1 Visitante están viendo este tema.

cpadilla

  • Full Member
  • ***
  • Mensajes: 107
    • Ver Perfil
  • Institución: UNPAZ
  • Nombre y apellido: Padilla Carlos Ismael
Consulta sobre los logs del sistema (RESPONDIDO)
« on: Abril 05, 2022, 11:11:58 am »
Buenas, le comento estamos haciendo una revisión sobre los logs del sistema y  visualizamos que almacena un tope de diez archivos sistema.log.x con un tamaño de un 1,1 M, donde podriamos ver ese bash o función donde realiza esa limitación.

Por otra parte los logs que se encuentran en la ruta ruta_instalacion/instalacion/i__produccion/p__diaguita/logs/web_services/ quedaron con registros viejos de cuando teniamos la versión 2.6.1, puede ser que en versiones posteriores ya no se lleva a cabo esos registros o me estaria faltando configurar algo?

Actualmente estamos en la versión 3.1.1
Saludos
« Última Modificación: Abril 05, 2022, 03:31:15 pm por Matias Deganis »

Pablo Boyko

  • Full Member
  • ***
  • Mensajes: 101
  • Desarrollador SIU-Diaguita
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Pablo Boyko
  • Sistema: SIU Diaguita
Re:Consulta sobre los logs del sistema
« Respuesta #1 on: Abril 05, 2022, 03:29:00 pm »
Hola Carlos,

Respecto al sistema.log te cuento que ese archivo de log lo gestiona el nucleo de toba.
Mediante la constante apex_log_archivo_backup_cant podrías redefinir la cantidad de archivos mantenidos por toba.
Por ej podrías probar aumentar la cantidad de archivos con un
Código: [Seleccionar]
define('apex_log_archivo_backup_cant', 15); en el archivo "ruta_instalacion_diaguita/www/aplicacion.php".

Respecto a los logs de los web services, estos archivos se generan directamente en el directorio: "ruta_instalacion/instalacion/i__produccion/p__diaguita/logs/" con los nombres de archivos web_services.log.
No se generan dentro del directorio /logs/web_services/.

Podrías probar consumiendo algún recurso REST de diaguita y verificar si se genera el archivo "logs/web_services.log".

Saludos.