Autor Tema: Actualización mapuche 3.4.4 a ultima versión  (Leído 134 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ebombara

  • Newbie
  • *
  • Mensajes: 8
    • Ver Perfil
  • Institución: Ministerio de Educación de la Nación
  • Nombre y apellido: Edgardo Bombara
  • Sistema: Mapuche
  • Teléfono laboral: 41291206
Actualización mapuche 3.4.4 a ultima versión
« on: Mayo 28, 2022, 01:54:06 pm »
Hola comunidad,
Espero puedan asistirme, llevo días tratando de migrar la versión 3.4.4 a la última versión, como paso previo estoy actualizando a la version 3.70 para luego poder actualizar a la ultima.
Durante la ejecución de Composer en los pasos previos: composer install --no-dev

[RuntimeException]
  Failed to execute git clone --no-checkout -- 'https://gitlab.siu.edu.ar/siu-si-libs/datum.git' '/usr/local/siu/mapuche_370/vendor/siu-si-libs/datum' --dissociate --reference '/root/.composer/cache/vcs/https---gitlab.siu.edu.ar-siu-s
  i-libs-datum.git/' && cd '/usr/local/siu/mapuche_370/vendor/siu-si-libs/datum' && git remote add composer -- 'https://gitlab.siu.edu.ar/siu-si-libs/datum.git' && git fetch composer
  Too many arguments.
  usage: git clone [<options>] [--] <repo> [<dir>]
....

¿Alguna recomendación?

Desde ya muchas gracias!

Nicolas Dominguez Florit

  • Moderador Mapuche
  • *
  • Mensajes: 702
    • Ver Perfil
    • SIU
    • Email
  • Institución: SIU
  • Nombre y apellido: Nicolas Dominguez Florit
  • Sistema: SIU-Mapuche
Re:Actualización mapuche 3.4.4 a ultima versión
« Respuesta #1 on: Mayo 30, 2022, 08:01:20 am »
Hola, como están? entiendo que el error se debe a alguna librería que cambio o algo producto de la antigüedad de la versión (la 3.17.0 es del 2019).
Una prueba que pueden realizar, es ejecutando el comando sin el no-dev.
Seria: "composer install"

Saludos, Nico