Autor Tema: Error al actualizar BD de 3.12 a 3.13  (Leído 231 veces)

0 Usuarios y 1 Visitante están viendo este tema.

asegade

  • Full Member
  • ***
  • Mensajes: 211
    • Ver Perfil
  • Institución: Universidad Nacional de los Comechingones
  • Nombre y apellido: Alberto Segade
  • Sistema: Mapuche
  • Teléfono laboral: 02656-446010
  • Utilizo algun sistéma del SIU: Sí
Error al actualizar BD de 3.12 a 3.13
« on: Noviembre 19, 2021, 06:11:43 pm »
Hola, buenos días!
Hicimos la actualización de Preinscripción desde la versión 3.12.0 a la 3.13.0, todos los pasos correctos, pero al querer actualizar la base de datos nos dio el siguiente error:
-----------------
postgres@siugua-unlc-db:/BACKUPDB$ psql -d preinscripcion < mig_3.12.0_a_3.13.0.sql
BEGIN
INSERT 0 1
DO
DO
NOTICE:  no existe la restricci�n �ck_sga_preinscripcion_propuestas_estado� en la relaci�n �sga_preinscripcion_propuestas�, ignorando
ALTER TABLE
ALTER TABLE
COMMIT
-----------------

La tabla app_versiones_base tiene lo siguiente:
 id_conversion | version_base |      fecha_actualizacion      | script_ejecutado |                observaciones               
---------------+--------------+-------------------------------+------------------+---------------------------------------------
             1 | 3.7          | 2018-09-13 16:42:47.50203-03  |                  | Versión 3.7 de la base de Preinscripción
             2 | 3.8          | 2019-07-03 08:54:36.584117-03 |                  | Version 3.8 de la base de Preinscripcion
             3 | 3.9          | 2019-07-03 11:39:52.887263-03 |                  | Version 3.9 de la base de Preinscripcion
             4 | 3.10         | 2021-05-12 20:13:59.732867-03 |                  | Versión 3.10 de la base de Preinscripción
             5 | 3.11         | 2021-05-12 20:14:17.982865-03 |                  | Versión 3.11 de la base de Preinscripción
             6 | 3.11.1       | 2021-05-12 20:14:34.589551-03 |                  | Versión 3.11.1 de la base de Preinscripción
             7 | 3.12         | 2021-05-13 11:36:11.322142-03 |                  | Versión 3.12 de la base de Preinscripción
             8 | 3.13         | 2021-11-19 18:03:23.52358-03  |                  | Versión 3.13 de la base de Preinscripción
(8 filas)

El servidor es un Linux Debian 9, Postgresql 11.

El sistema de Preinscripción quedó funcionando normalmente con la versión 3.13.0

Desde ya muchas gracias
« Última Modificación: Noviembre 19, 2021, 07:33:58 pm por asegade »

jzeitune

  • Hero Member
  • *****
  • Mensajes: 702
    • Ver Perfil
    • Email
  • Institución: UNT
  • Nombre y apellido: Javier Zeitune
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar BD de 3.12 a 3.13
« Respuesta #1 on: Junio 03, 2022, 10:37:42 am »
Buenos días, tuvimos el mismo inconveniente, se solucionó?

Saludos

asegade

  • Full Member
  • ***
  • Mensajes: 211
    • Ver Perfil
  • Institución: Universidad Nacional de los Comechingones
  • Nombre y apellido: Alberto Segade
  • Sistema: Mapuche
  • Teléfono laboral: 02656-446010
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar BD de 3.12 a 3.13
« Respuesta #2 on: Junio 03, 2022, 10:47:47 am »
Hola Javier, ignoramos el problema y seguimos adelante. No trajo problemas.
Saludos

jzeitune

  • Hero Member
  • *****
  • Mensajes: 702
    • Ver Perfil
    • Email
  • Institución: UNT
  • Nombre y apellido: Javier Zeitune
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar BD de 3.12 a 3.13
« Respuesta #3 on: Junio 03, 2022, 10:49:34 am »
Muchas gracias!