Autor Tema: Debian 11  (Leído 104 veces)

0 Usuarios y 1 Visitante están viendo este tema.

achrabatyn

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
    • Email
  • Institución: UNLZ
  • Nombre y apellido: Alejandro Daniel Chrabatyn
  • Sistema: COMDOC - MAPUCHE - PAMPA
  • Teléfono laboral: 4282-8044
Debian 11
« on: Septiembre 08, 2022, 12:43:00 am »
Buenas estoy tratando de hacer una instacion de 0 en debian 11 , postgres 9.6 , jdk 1.7.0_8 , postgresql-42.2.26.jre7.jar y no me esta levantando bi
log
catalina.2022-09-08.log
 org.apache.catalina.startup.Catalina.start Server startup in 44555 ms


/catalina.out
ERROR [EmbeddedQuartzSystemListener] EmbeddedQuartzSystemListener.ERROR_0007_SQLERROR
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (ERROR: relation "information_schema.system_sequences" does not exist

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 540
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Sistema: Wichi
  • Utilizo algun sistéma del SIU: Sí
Re:Debian 11
« Respuesta #1 on: Septiembre 08, 2022, 09:52:07 am »
Hola Alejandro, si necesitas ayuda para la instalación, hacemos un meet y lo vemos.
Saludos,
Sabrina.

mortuno

  • Newbie
  • *
  • Mensajes: 5
    • Ver Perfil
  • Institución: Universidad Nacional del Comahue
  • Nombre y apellido: Ortuño Matias Jose
  • Sistema: SIU Guarani, SIU Wichi
  • Teléfono laboral: 0299 4490467
  • Utilizo algun sistéma del SIU: Sí
Re:Debian 11
« Respuesta #2 on: Septiembre 23, 2022, 12:24:39 pm »
Buenos días. ¿Qué tal? Aprovecho este hilo para realizar una consulta relacionada, ya que nosotros también estamos pensando en hacer una instalación desde cero con la última versión del SIU Wichi (6.11). Principalmente debido a que la versión del Debian sobre la que está corriendo el actual sistema en producción ha dejado de tener soporte y buscamos reemplazarlo por alguno que lo tenga a largo plazo.

La duda es la siguiente:

Dentro de los requerimientos de software en la última guía técnica se especifica que se debe cumplir lo siguiente:

-Debian 6.0 o superior (optamos por Debian en lugar de Ubuntu).
En este aspecto las versiones aún con soporte al día de la fecha son la 10 (Buster) y 11 (Bullseye).

-Postgresql 9.6 o superior (hasta 10.0)
El inconveniente entre estas versiones y las de Debian mencionadas anteriormente (Buster y Bullseye) es que las mismas trabajan (al menos por defecto) con versiones de postgresql 11 en adelante.

-Java JRE version 1.7
El enlace de la guía técnica para descargar los drivers POSTGRESQL JDBC no está funcionando (entiendo que por actualización de la web) pero buscando en la página oficial de JDBC se encuentran los drivers para versiones 42.2.xx en adelante.

En conclusión: Según su experiencia actual, ¿con qué versiones recomendarían trabajar? Si se opta por un S.O Debian con soporte a la fecha entonces habrá problemas de compatibilidad con la versión de Postgresql? ¿o ya lo han testeado?
 
Por otra parte, ¿la versión de Java que se debe seguir utilizando es la 1.7.0? ¿o las versiones actuales de Java (como por ejemplo Java 8 v42.5.0) son compatibles e incluyen las anteriores? ¿habrá inconvenientes a la hora de correr los scripts con versiones nuevas?
¿Qué configuración recomiendarían ustedes como más eficiente y robusta?

Todo consejo, sugerencia y conocimiento al respecto es más que bienvenido. Aguardo por comentarios.

Gracias, saludos.

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 540
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Sistema: Wichi
  • Utilizo algun sistéma del SIU: Sí
Re:Debian 11
« Respuesta #3 on: Septiembre 26, 2022, 09:40:55 am »
Buen día Matias, te cuento que nosotros migramos nuestras instalaciones del demo y otras e instalamos lo siguiente:
- Debian 11
- Postgres 12
- Java 1.8
 Te dejo el link de descarga del Jar para postgres 12 y del java 1..8.
- Jar Postgres 12 --> https://drive.google.com/file/d/1gCp5E28f4uhPMBhxReGRYXiW-dnIDTgu/view?usp=sharing
- Java --> https://drive.google.com/file/d/1tL6-8ZnwS1oRG119SvKqImuIMdnqi7C5/view?usp=sharing

Saludos,
Sabrina