Autor Tema: Error al migrar Kolla 4.5 a 4.7.2  (Leído 136 veces)

0 Usuarios y 1 Visitante están viendo este tema.

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Error al migrar Kolla 4.5 a 4.7.2
« on: Noviembre 08, 2022, 01:07:04 pm »
Buenas tardes, espero que anden bien!!!
Después de varias consultas al foro logré ahcer correr casi por completa la actualización ... pero me sigue dando éste error y ya no sé que más hacer
Cita
[2022-11-08 15:16:25] MAIN.INFO: [ TOBA ] PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function consola::mensaje(), 0 passed in
/usr/local/proyectos/kolla/php/modelo/migraciones/kolla_migrador.php on line 48 and at least 1 expected in
/usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/consola.php:129
Stack trace: #0 /usr/local/proyectos/kolla/php/modelo/migraciones/kolla_migrador.php(48): consola->mensaje()
#1 /usr/local/proyectos/kolla/php/extension_toba/kolla_modelo.php(104): kolla_migrador->migrar()
#2 /usr/local/proyectos/kolla/php/extension_toba/kolla_comando.php(24): kolla_modelo->migrar_modelo()
#3 /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/comandos/comando_proyecto.php(87): kolla_comando->opcion__migrar_modelo()
#4 /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/comando.php(90): comando_proyecto->ejecutar_opcion()
#5 /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/consola.php(78): comando->procesar()
#6 /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/c in /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/consola/consola.php on line 129 

Alguna ayuda???
Saludos
Juan Pablo

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #1 on: Noviembre 08, 2022, 01:27:32 pm »
Quiero agregar el mensaje que me dá el log de error de apache
Cita
[Tue Nov 08 16:24:53.714442 2022] [php7:warn] [pid 3959892] [client 10.10.1.1:49290] PHP Warning:  require_once(/usr/local/proyectos/kolla/metadatos_compilados/gene/toba_mc_gene__basicos.php): failed to open stream: No such file or directory in /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/nucleo/toba_nucleo.php on line 515
[Tue Nov 08 16:24:53.714524 2022] [php7:error] [pid 3959892] [client 10.10.1.1:49290] PHP Fatal error:  require_once(): Failed opening required '/usr/local/proyectos/kolla/metadatos_compilados/gene/toba_mc_gene__basicos.php' (include_path='/usr/local/proyectos/kolla/vendor/siu-toba/structures_graph:/usr/local/proyectos/kolla/vendor/siu-toba/numbers_words:/usr/local/proyectos/kolla/vendor/pear/pear_exception:.:/usr/share/php:.:/usr/local/proyectos/kolla/vendor/siu-toba/framework/php:.:/usr/local/proyectos/kolla/php') in /usr/local/proyectos/kolla/vendor/siu-toba/framework/php/nucleo/toba_nucleo.php on line 515

Saludos

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #2 on: Noviembre 09, 2022, 12:27:38 pm »
Hola Juan Pablo, podrías adjuntar el archivo instalador.log ubicado en la raíz de la carpeta donde está instalado Kolla?. Los pasos que seguiste para actualizar son los que figuran acá https://documentacion.siu.edu.ar/wiki/SIU-Kolla/Version_4.7.0/actualizacion?

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #3 on: Noviembre 09, 2022, 01:45:24 pm »
Adjunto el log.
Si, he seguido los pasos pero tuve que agregar a mano la retua de la instalación anterior por que sino fallaba

Saludos
Juan Pablo

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #4 on: Noviembre 09, 2022, 02:50:42 pm »
Efectivamente, la ruta a la instalacion anterior tenés que indicarsela vos de lo contrario el instalador no sabe donde se encuentra. De todas maneras te cuento que en los logs veo varios intentos de actualización fallidos. Es decir que nunca se llegó a actualizar efectivamente a la 4.7.2. Luego sobre el final veo que hay un intento de actualizar una 4.7.2 sobre una versión 4.7.2 con lo cuál todo queda en un estado inconsistente.

Deberías intentar nuevamente una actualización. Para esto tenés que restaurar los directorios originales de la 4.5 (si es que los modificaste por algún motivo, de lo contrario no tenés que hacer nada) y restaurar un backup de la base de 4.5 y comenzar nuevamente todo el proceso de actualización. Cuando llegues al punto donde te pregunta el path de la instalación anterior, deberías indicarle el path completo a la raíz donde está instalado Kolla 4.5.

En tu caso veo que estás intentando colocar el path /usr/local/proyectos/kolla4.5 pero el instalador no encuentra una instalación de 4.5 en ese lugar. Revisá el archivo entorno_toba.env que se encuentra en la raíz y chequea los paths que figuran allí. Si querés adjuntarme ese archivo sería de gran ayuda.

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #5 on: Noviembre 10, 2022, 01:29:42 pm »
Buenas tardes,
Si, varios intentos por que no me daba éste error
Cita
4) Verificación del proyecto existente
======================================


 [ ERROR ] El directorio "" no tiene permisos de lectura
PHP Warning:  parse_ini_file(/i__produccion/instancia.ini): failed to open stream: No such file or directory in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 197
PHP Notice:  Trying to access array offset on value of type bool in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 199
PHP Notice:  Trying to access array offset on value of type null in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 199

 [ ERROR ] No se pudo leer el archivo "/proyecto.ini"
PHP Warning:  parse_ini_file(/i__produccion/instancia.ini): failed to open stream: No such file or directory in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 19
PHP Notice:  Trying to access array offset on value of type bool in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 21
PHP Notice:  Trying to access array offset on value of type null in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 21
PHP Warning:  parse_ini_file(/proyecto.ini): failed to open stream: No such file or directory in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 25
PHP Notice:  Trying to access array offset on value of type bool in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 27
PHP Notice:  Trying to access array offset on value of type null in /usr/local/proyectos/kolla/php/Instalador/Paso/VerificarProyectoKollaExistente.php on line 27
PHP Warning:  parse_ini_file(/i__produccion/instancia.ini): failed to open stream: No such file or directory in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 214
PHP Notice:  Trying to access array offset on value of type bool in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 216
PHP Warning:  array_key_exists() expects parameter 2 to be array, null given in /usr/local/proyectos/kolla/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 216

 [ ERROR ] El archivo "/i__produccion/instancia.ini" debe tener configurado el parámetro usar_perfiles_propios = "1" en la entrada [kolla], para que se puedan migrar los perfiles funcionales.
que ahora sigue dando y no puedo saltarlo
He seguido por supuesto paso a paso la documentación
Tengo un snapshot de la vertsión 4.5 funcionando, por lo que he vuelo para atrás, he actualizado el php al 7.4 y he intentado la actualización ... pero en todos los casos me dió ese error. Cambié permisos y propietarios por todos lados pero nada
que puede estar pasando???

Saludos
Juan Pablo
« Última Modificación: Noviembre 10, 2022, 01:35:42 pm por chardonay »

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #6 on: Noviembre 10, 2022, 01:33:46 pm »
Podrías adjuntar los archivos que mencioné anteriormente?

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #7 on: Noviembre 10, 2022, 01:36:02 pm »
Adjuntado al mensaje anterior

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #8 on: Noviembre 10, 2022, 01:40:03 pm »
Necesito el archivo entorno_toba.env

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #9 on: Noviembre 10, 2022, 01:43:23 pm »
Adjunto .... éste archivo lo toqué para que tuviese bien la ruta (lo leí en alguna parte del foro)

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #10 on: Noviembre 10, 2022, 01:51:24 pm »
Si tuviste que editar este archivo entonces el problema es otro. Ese archivo no debería editarse ya que lo genera automáticamente la instalación. Podrías adjuntarme una captura de pantalla con el contenido de la carpeta

Código: [Seleccionar]
/usr/local/proyectos/kolla4.5

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #11 on: Noviembre 10, 2022, 02:20:33 pm »
Una vez más volví todo para atrás y no renombré la carpeta kolla original ... creé una nueva con el contenido del kolla4.7... mismo error!!!!!
adjunto los directorios de ambas carpetas

Saludos

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #12 on: Noviembre 10, 2022, 03:13:24 pm »
Bueno, repasemos. La instalación de 4.5 se encuentra en

Código: [Seleccionar]
/usr/local/proyectos/kolla
Si revisas el archivo

Código: [Seleccionar]
/usr/local/proyectos/kolla/entorno_toba.env
deberías tener lo siguiente:

Código: [Seleccionar]
export TOBA_DIR=/usr/local/proyectos/kolla/vendor/siu-toba/framework
export TOBA_INSTANCIA=produccion
export TOBA_INSTALACION_DIR=/usr/local/proyectos/kolla/instalacion
export PATH="$TOBA_DIR/bin:$PATH"
# "Entorno cargado."
# "Ejecute 'bin/toba' para ver la lista de comandos disponibles."

Si no es el caso, deberías ajustarlo a esos paths. Insisto en que este archivo no debería haber cambiado. La instalación de la 4.5 tiene que haber dejado esos paths ya seteados, pero no está mal revisarlos.

Una vez chequeado esto deberías pararte en

Código: [Seleccionar]
/usr/local/proyectos/kolla4.7
E iniciar el proceso de actualización

Código: [Seleccionar]
./bin/instalador proyecto:actualizar
Y cuando te pregunte por el path donde está instalada la versión 4.5 de kolla deberías indicarle

Código: [Seleccionar]
/usr/local/proyectos/kolla
Si la actualización te falla en el mismo punto te voy a pedir que nos adjuntes los siguientes archivos:

  • /usr/local/proyectos/kolla4.7/instalador.log
  • /usr/local/proyectos/kolla4.7/instalador.env
  • /usr/local/proyectos/kolla/instalador.env
  • /usr/local/proyectos/kolla/instalador.log

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #13 on: Noviembre 10, 2022, 06:56:25 pm »
Perfecto ... actualización realizada, tenía 2 problemas
1- El composer me tiraba algunos mensajes por que no estaban todos los paquetes de php7.4 instalados, por ejemplo, php7.4-raphf y php7.4-propro
2- La ruta siempre la dejé con la barra final (/usr/local/proyectos/kolla/)

Gracias por el tiempo dedicado
Saludos

Juan Pablo Arango

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 207
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error al migrar Kolla 4.5 a 4.7.2
« Respuesta #14 on: Noviembre 11, 2022, 07:45:11 am »
De nada. Saludos.