Autor Tema: [RESPONDIDO] Error en integración Sudocu-Pilaga  (Leído 69 veces)

0 Usuarios y 1 Visitante están viendo este tema.

lrinaudo

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Universidad Nacional de Quilmes
  • Nombre y apellido: Leandro Rinaudo
  • Sistema: Mapuche, Diaguita, Pilaga, toba
  • Utilizo algun sistéma del SIU: Sí
[RESPONDIDO] Error en integración Sudocu-Pilaga
« on: Noviembre 24, 2022, 10:57:27 am »
Hola, queremos integrar Sudocu con Pilaga y tenemos un problema cuando vamos a:

Gastos -> Compras -> Preventivo compras -> Preventivo compras - alta

Pilaga nos muestra el siguiente error:

Se ha producido un problema al intentar obtener los tramites electrónicos, revise si la configuración con Sistema de Gestión Documental es correcta.

El log de pilaga logs/docs-cli.log muestra el siguiente error:

[2022-11-24 10:43:08] docs-cli.ERROR: Error getTramites, codigo 500. Mensaje: Server error: `GET https://arai-labo.unq.edu.ar/api-usuarios/v2/rest/backend/tramites?id_usuario=leandro.rinaudo` resulted in a `500 Internal Server Error` response:
{
    "error": 500,
    "mensaje": "500 Internal Server Error",
    "descripcion": "Error Interno en el servidor: No se encuentra el recurso para rest\/backend\/tramites en el directorio \/usr\/local\/app\/api\/src\/SIU\/AraiUsuarios\/API\/Endpoints\/v2. \u00bfRuta mal formada?"
 para usuario: leandro.rinaudo [] []

Seguimos toda la documentación de como integrar, ya tenemos pilaga y sudocu autenticando contra arai usuarios, usuarios api esta levantado y creemos que correctamente porque cuando probamos ejecutar el siguiente comando (desde el servidor donde está pilaga):

curl https://arai-labo.unq.edu.ar/api-usuarios/v2/info -u user:pass

nos responde lo siguiente:

[
    {
        "nombre": "Arai-Usuarios",
        "version": "v3.1.3",
        "api_version": "2.1",
        "api_major": 2,
        "api_minor": 1
    }
]

También modificamos los parametros de Pilaga enviar_firma_digital y guardar_comprobante_3ros_arai_doc al valor "SI". Por último en instalador.env de pilaga tenemos lo siguiente:

##### CONFIG API DOCUMENTOS #####
DOCUMENTOS_HOST=https://arai-labo.unq.edu.ar/api-usuarios/v2
DOCUMENTOS_USUARIO=user
DOCUMENTOS_CLAVE=pass

y en instalacion/i__produccion/p__toba_usuarios/rest/rest_arai_usuarios/cliente.ini:

;[conexion]
;;Recuerde dejar una barra (/) al finalizar la URL
to = "https://arai-labo.unq.edu.ar/api-usuarios/v2/"
auth_tipo = basic
auth_usuario = user
auth_password = pass

Que es lo que estamos haciendo mal ? Obviamente el usuario existe en arai y tambien en sudocu.

Muchas Gracias!

« Última Modificación: Noviembre 24, 2022, 01:24:29 pm por Alejandro Schvindtt »

Alejandro Schvindtt

  • Moderador
  • *****
  • Mensajes: 78
    • Ver Perfil
    • Email
  • Institución: SIU
  • Sistema: EEI
  • Utilizo algun sistéma del SIU: Sí
Re:Error en integración Sudocu-Pilaga
« Respuesta #1 on: Noviembre 24, 2022, 01:24:02 pm »
Hola Leandro, buenas tardes. ¿Cómo estás?
Según el log que nos copias, vemos que están queriendo obtener los trámites desde la api de usuarios:

[2022-11-24 10:43:08] docs-cli.ERROR: Error getTramites, codigo 500. Mensaje: Server error: `GET https://arai-labo.unq.edu.ar/api-usuarios/v2/rest/backend/tramites?id_usuario=leandro.rinaudo` resulted in a `500 Internal Server Error`

Cuando deberían consultar la api de trámites:

GET https://arai-labo.unq.edu.ar/documentos/rest/backend/tramites?id_usuario=leandro.rinaudo

Nos mantenemos en contacto ante cualquier problema que surja al realizar el ajuste.
Saludos,
Alejandro.


lrinaudo

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Universidad Nacional de Quilmes
  • Nombre y apellido: Leandro Rinaudo
  • Sistema: Mapuche, Diaguita, Pilaga, toba
  • Utilizo algun sistéma del SIU: Sí
Re:[RESPONDIDO] Error en integración Sudocu-Pilaga
« Respuesta #2 on: Noviembre 29, 2022, 10:56:32 am »
Muchas gracias por la respuesta Alejandro, cambié en el instalador.env de pilaga la configuración de api documentos de la siguiente manera:

##### CONFIG API DOCUMENTOS #####
DOCUMENTOS_HOST=https://arai-labo.unq.edu.ar/docs

y nos seguía fallando, mirando los logs del conenedor de docs vimos que habia un error 404 cuando le dabamos F5 en pilaga a:

Gastos-> Compras ->Preventivo compras->Preventivo compras - alta

el error era en la ruta, estaba 2 veces la palabra integración, la ruta era .../integracion/integracion..., para corregir eso modificamos el secrets.sh de arai de la siguiente manera:

# Conexión con Sudocu
DOCS_CONEXION_SUDOCU=$(cat << EOF
"{base_uri:'http://api-server:8080/',method:'basic',user:'integracion',password:'integracion'}"
EOF
)

antes la base_uri era 'http://api-server:8080/integracion', asi que le sacamos /integracion de esa ruta y dejó de tirar el error 404 el contenedor docs.

Ahora tenemos el mismo error en pilaga:

Se ha producido un problema al intentar obtener los tramites electrónicos, revise si la configuración con Sistema de Gestión Documental es correcta

pero el archivo logs/docs-cli.log no tira ningún error, lo único que muestra es lo siguiente:

[2022-11-29 10:49:08] docs-cli.INFO: URL GET: backend/tramites?id_usuario=leandro.rinaudo [] []

Si entro manualmente a la ruta https://arai-labo.unq.edu.ar/docs/rest/backend/tramites?id_usuario=leandro.rinaudo el resultado es el siguiente:

{
    "id_usuario_sso": "leandro.rinaudo",
    "id_area": null,
    "listado": []
}

y ni en el contenedor docs, ni en sudocu tira nigún tipo de error los logs, todas las pegadas son 200OK, hay algún archivo de log que muestre que es lo que está fallando? o cuál puede ser el problema?

Muchas gracias!
Leandro.