Autor Tema: Problemas con JDBC driver en SIU-Wichi 6.11.0  (Leído 174 veces)

0 Usuarios y 1 Visitante están viendo este tema.

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Problemas con JDBC driver en SIU-Wichi 6.11.0
« on: Diciembre 02, 2022, 11:39:40 am »
Buenos días, espero que se encuentren bien.
Le cuento que estoy instalando en un servidor nuevo el Wichi 6.11.0 en un Debian 11, Java version "1.8.0_333" y Postgres 9.6 (como dice el manual de Instalación). Pero no logro encontrar el driver compatible entre es Java 8 y el Postgres 9.6.
No tengo problemas en bajar a Java 7 y bien en subir la versión de Postgres, pero ... que sería lo ideal en éste caso?
Muchas Gracias
Saludos
Juan Pablo

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 545
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Sistema: Wichi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con JDBC driver en SIU-Wichi 6.11.0
« Respuesta #1 on: Diciembre 02, 2022, 01:00:30 pm »
Hola Juan Pablo! nosotros hicimos actualización en nuestro demo y utilizamos Debian 11, java 1.8 y postgres 12, todo funciona perfectamente.
Este es el driver que utilice https://drive.google.com/file/d/1gCp5E28f4uhPMBhxReGRYXiW-dnIDTgu/view?usp=sharing

Saludos,
Sabrina.

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Problemas con JDBC driver en SIU-Wichi 6.11.0
« Respuesta #2 on: Diciembre 07, 2022, 10:55:56 am »
Hola Sabri, como andas???
Me sigue dando éste error que te adjunto ... además te paso algunos recortes del log que dá algunos errores extraños y luego el error que tira cuendo quiero hacer el test de la conexión.

Saludos
Juan Pablo

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 545
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Sistema: Wichi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con JDBC driver en SIU-Wichi 6.11.0
« Respuesta #3 on: Diciembre 07, 2022, 11:26:24 am »
Hola Juan Pablo, tendrias que revisar tres cosas:
* Que tengas el driver de postgres en /usr/local/pentaho/biserver-ce/tomcat/lib/.
* Que tengas la conexion JNDI en /usr/local/pentaho/biserver-ce/tomcat/webapps/pentaho/WEB-INF/web.xml  (Paso 2 del punto 3.2 de la guia)
* Que tengas bien la conexion a la base wichi en /usr/local/pentaho/biserver-ce/tomcat/webapps/pentaho/META-INF/context.xml (Paso 3 del punto 3.2 de la guia)

Si sigue sin funcionar coordinamos un meet.
Saludos,
Sabrina

chardonay

  • Full Member
  • ***
  • Mensajes: 188
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Juan Pablo Arango
  • Sistema: Pilaga
  • Teléfono laboral: 0261 - 4135000 int 4176
Re:Problemas con JDBC driver en SIU-Wichi 6.11.0
« Respuesta #4 on: Diciembre 07, 2022, 12:51:36 pm »
Sabri, te adjunto los archivos
Te cuento que hice la conexión del Paso 5 como Native (JDBC) y no JNDI. Si bien funciona no he probado correr algún proceso para armar algún cubo.
Espero tus comentarios
Saludos
Juan Pablo

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 545
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Sistema: Wichi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con JDBC driver en SIU-Wichi 6.11.0
« Respuesta #5 on: Diciembre 07, 2022, 01:20:10 pm »
Sin JNDI no te van a funcionar los tableros, con los cubos no vas a tener problemas.
Borra el driver de postgres 9.3 y reinicia