Autor Tema: Problemas para imprimir  (Leído 2374 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Nicolas

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Lujan
  • Nombre y apellido: Nicolas Dovico
  • Sistema: Toba
  • Teléfono laboral: 02323-434417
Problemas para imprimir
« on: Septiembre 24, 2010, 12:40:02 pm »
Hola Eugenia:

Estamos teniendo el siguiente problema con la instalación. Paso a hacerte un resumen de qué pasos se fueron siguiendo:

Tenemos la instalación realizada sobre un servidor SIN entorno gráfico.
Realizando las primeras pruebas notamos que en las carátulas no se mostraba el código de barras del documento creado y la impresión de la misma funcionaba correctamente. Viendo que era lo que estaba pasando vimos que el servidor X Virtual (el encargado de generar los códigos de barras no estaba levantado). Levantamos el servicio ejecutando los demonios xvfb-daemon y xvfb-daemon2. Ademas tuvimos que descargar e instalar el paquete de Debian "xorg" (recordar que no tenemos entorno grafico en el servidor). Una vez hecho esto restarteamos el jboss y los dos demonios y logramos generar y visualizar los codigos de barra. Pero de aquí en mas, la impresión de las carátulas desde la aplicación Comdoc comenzó a arrojar el mensaje de error que se adjunta.
Luego, procedimos a bajar el servidor X Virtual con lo cual logramos que la impresión funcionara pero ya no podemos generar ni visualizar los códigos de barra.
En resúmen, con el servidor X virtual levantado generamos y vemos códigos de barra pero no podemos imprimir desde la aplicación. Bajando este servicio podemos imprimir pero no generar ni ver códigos de barra.
Alguna idea sobre lo que puede estar pasando?
Adjunto el server.log
Espero haber sido claro, de antemano, muchas gracias

Nicolas
UNLU


Eugenia Calvo

  • Moderador Global
  • *****
  • Mensajes: 133
    • Ver Perfil
    • Email
Re: Problemas para imprimir
« Respuesta #1 on: Abril 27, 2011, 10:56:35 am »
Hola Nicolas,

no se si ya resolviste el tema pero aparentemente el que genera problemas es la openjdk, deberías descargarte y reemplazarla por la jdk de SUN.
Saludos
Eugenia Calvo
Sistema de Información Universitaria (SIU)
Tel +54 249 443.2304
www.siu.edu.ar

gpautsch

  • General Guarani
  • *
  • Mensajes: 20
    • Ver Perfil
    • Email
  • Institución: FCEQyN y FCE - UNaM
  • Nombre y apellido: Lic. German Pautsch
  • Sistema: SIU Guarani y Kolla
  • Teléfono laboral: 1
Re:Problemas para imprimir
« Respuesta #2 on: Marzo 01, 2012, 05:32:30 pm »
Como estas Nicolas.
Solucionaste este tema. A mi me pasa exactamente lo mismo que a vos.
Saludos

 Lic. J. Germán A. Pautsch
Licenciado en Sistemas de Información
     msn: gpautsch@hotmail.com
       skype: german_pautsch
-----------------------------------------
Universidad Nacional de Misiones
Facultad de Ciencias Economicas
www.fce.unam.edu.ar
Ruta Nacional 12, Km. 7,5 - (N3304)
Miguel Lanus - Misiones - Argentina
Tel: (0376) 448-0006 / 448-0394 / 448-0395
Fax: (0376) 448-0988

Nicolas

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Lujan
  • Nombre y apellido: Nicolas Dovico
  • Sistema: Toba
  • Teléfono laboral: 02323-434417
Re:Problemas para imprimir
« Respuesta #3 on: Marzo 05, 2012, 09:59:50 am »
Germán:

Lo que hicimos fue actualizar la openjdk según lo que nos recomendó Eugenia, y luego, actualizar el resto del software del servidor con lo último del repositorio de Debian. Reiniciamos el jboss y salió funcionando.

gpautsch

  • General Guarani
  • *
  • Mensajes: 20
    • Ver Perfil
    • Email
  • Institución: FCEQyN y FCE - UNaM
  • Nombre y apellido: Lic. German Pautsch
  • Sistema: SIU Guarani y Kolla
  • Teléfono laboral: 1
Re:Problemas para imprimir
« Respuesta #4 on: Marzo 20, 2012, 03:13:58 pm »
Solucionado el tema que  no muestra los codigos de barras.
Lo que me pasaba es que yo realizaba las pruebas ejecutando el jboss desde consola de esta manera:
./run.sh -b 0.0.0.0 -c $INSTANCIA -Dcomdoc.dir=/usr/local/jboss/server/comdoc

el problema es que aqui no se setea la variame de entorno  DISPLAY=localhost:0.0
que si se setea en el /etc/init.d/jboss_init.sh.

Saludos
German

Eugenia Calvo

  • Moderador Global
  • *****
  • Mensajes: 133
    • Ver Perfil
    • Email
Re:Problemas para imprimir
« Respuesta #5 on: Marzo 20, 2012, 03:20:40 pm »
Hola Germán, gracias por compartir la solución!
saludos
Eugenia
Eugenia Calvo
Sistema de Información Universitaria (SIU)
Tel +54 249 443.2304
www.siu.edu.ar