Autor Tema: UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios  (Leído 2371 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pvidal

  • Sr. Member
  • ****
  • Mensajes: 376
    • Ver Perfil
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Paola Beatriz Vidal
  • Sistema: SIU-Mapuche, SIU-Pilaga
  • Teléfono laboral: 0297-4854888 int. 114
Buen dia Leo,

¿Cómo estás? Te comento que estoy en el paso 2. Configurar interacción entre servicios del instructivo. El primer ítem lo pude configurar sin problemas, el tema es el segundo: $ {ruta_al_sistema}/arai/toba/bin/toba servicios_web cli_configurar -p arai -i produccion -s
serv_encriptado_firmado -c {ruta_al_certificado_autogestion}/publica.crt
Cuando ejecuto este comando me sale la pantalla adjunta denominada UNPA_PASO2-INTERAC. ENTRE SERV. ITEM 2 donde me pide ingresar un ID, debo ingresar el nombre de los 3 ID?

Cuando ejecuto el comando $ {ruta_al_sistema}/pilaga/toba/bin/toba servicios_web serv_configurar -p pilaga -i produccion -h
cliente=autogestion -c {ruta_al_certificado_autogestion}/publica.crt, me sale el mismo error que te había reportado al momento de instalar el Arai. Probe ejecutar los comandos que me enviaste (toba instancia info -i desarrollo y también toba instancia info -i produccion), pero me sigue saliendo el mismo error. Este mismo error se me presenta en los siguientes ítems ya que todos hacen referencia a la instancia de pilaga¿Qué puede ser?
Te adjunto la imagen denominada UNPA_PASO2-INTERAC. ENTRE SERV. ITEM 3


- Aprovecho pare decirte también que en la configuración del archivo webservice.ini que se encuentra dentro de ../arai/php/configuración tomé el archivo que estaba en la maquina virtual y no el que estaba en el compactado de Arai que baje de la extranet. Esto es porque en el archivo que se encuentra en la maquina virtual se encuentran las siguientes lineas:

cert_cliente = 'instalacion/i__produccion/p__arai/publica.crt'
clave_cliente = 'instalacion/i__produccion/p__arai/privada.key'
cert_server = 'instalacion/i__produccion/p__arai/publica.crt'


Espero tu respuesta

Desde ya muchas gracias por la ayuda brindada!


Saludos
Paola Vidal
Universidad Nacional de la Patagonia Austral
« Última Modificación: Noviembre 04, 2013, 02:02:35 pm por pvidal »

Leonardo Ramirez

  • Moderador
  • *****
  • Mensajes: 228
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #1 on: Noviembre 05, 2013, 01:07:29 pm »
Paola,

Te paso las líneas que reemplazarían a la segunda que te pide que agregues el ID del servicio, estas líneas ya lo incluyen como parámetro:

$ {ruta_al_sistema}/arai/toba/bin/toba servicios_web serv_configurar -p arai -i produccion -h cliente=autogestion -s ServicioAutorizantes -c {ruta_a_autogestion}/config/publica.crt

$ {ruta_al_sistema}/arai/toba/bin/toba servicios_web serv_configurar -p arai -i produccion -h cliente=autogestion -s ServicioTramites -c {ruta_a_autogestion}/config/publica.crt

Respecto al problema para ejecutar el comando toba en el Toba de Pilagá prueben de cargar el entorno levantando las variables de entorno que se encuentran en el archivo cuyo nombre comienza con entorno_toba

Saludos
Leo

Buen dia Leo,

¿Cómo estás? Te comento que estoy en el paso 2. Configurar interacción entre servicios del instructivo. El primer ítem lo pude configurar sin problemas, el tema es el segundo: $ {ruta_al_sistema}/arai/toba/bin/toba servicios_web cli_configurar -p arai -i produccion -s
serv_encriptado_firmado -c {ruta_al_certificado_autogestion}/publica.crt
Cuando ejecuto este comando me sale la pantalla adjunta denominada UNPA_PASO2-INTERAC. ENTRE SERV. ITEM 2 donde me pide ingresar un ID, debo ingresar el nombre de los 3 ID?

Cuando ejecuto el comando $ {ruta_al_sistema}/pilaga/toba/bin/toba servicios_web serv_configurar -p pilaga -i produccion -h
cliente=autogestion -c {ruta_al_certificado_autogestion}/publica.crt, me sale el mismo error que te había reportado al momento de instalar el Arai. Probe ejecutar los comandos que me enviaste (toba instancia info -i desarrollo y también toba instancia info -i produccion), pero me sigue saliendo el mismo error. Este mismo error se me presenta en los siguientes ítems ya que todos hacen referencia a la instancia de pilaga¿Qué puede ser?
Te adjunto la imagen denominada UNPA_PASO2-INTERAC. ENTRE SERV. ITEM 3


- Aprovecho pare decirte también que en la configuración del archivo webservice.ini que se encuentra dentro de ../arai/php/configuración tomé el archivo que estaba en la maquina virtual y no el que estaba en el compactado de Arai que baje de la extranet. Esto es porque en el archivo que se encuentra en la maquina virtual se encuentran las siguientes lineas:

cert_cliente = 'instalacion/i__produccion/p__arai/publica.crt'
clave_cliente = 'instalacion/i__produccion/p__arai/privada.key'
cert_server = 'instalacion/i__produccion/p__arai/publica.crt'


Espero tu respuesta

Desde ya muchas gracias por la ayuda brindada!


Saludos
Paola Vidal
Universidad Nacional de la Patagonia Austral

pvidal

  • Sr. Member
  • ****
  • Mensajes: 376
    • Ver Perfil
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Paola Beatriz Vidal
  • Sistema: SIU-Mapuche, SIU-Pilaga
  • Teléfono laboral: 0297-4854888 int. 114
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #2 on: Noviembre 05, 2013, 01:56:22 pm »
Leo,
Cuando ejecutamos el comando ./entorno_toba_2.3.sh, el entorno se carga correctamente. Este archivo contiene las siguientes variables:

export toba_dir=/var/www/pilaga/toba
export toba_instancia=produccion
export toba_instalacion_dir=/var/www/pilaga/instalacion
export PATH="$toba_dir/bin:$PATH"

Pero cuando ejecutamos el comando /var/www/pilaga/toba/bin$./toba instancia info -i produccion sale el mismo error..

Gracias

Paola

Leonardo Ramirez

  • Moderador
  • *****
  • Mensajes: 228
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #3 on: Noviembre 06, 2013, 10:25:44 am »
Paola,

Haciendo referencia a la respuesta del otro tema por el cual están consultando, me da la sensación que tienen Pilaga instalado con instalador (principalmente por la ruta donde tienen instalado toba, en /var/www/pilaga/toba), pero me desorienta el hecho de que están usando un toba editor donde tienen cargado Araí.
Espero la respuesta de que tienen instalado en cada entorno para poder responderte.

Saludos

Leo,
Cuando ejecutamos el comando ./entorno_toba_2.3.sh, el entorno se carga correctamente. Este archivo contiene las siguientes variables:

export toba_dir=/var/www/pilaga/toba
export toba_instancia=produccion
export toba_instalacion_dir=/var/www/pilaga/instalacion
export PATH="$toba_dir/bin:$PATH"

Pero cuando ejecutamos el comando /var/www/pilaga/toba/bin$./toba instancia info -i produccion sale el mismo error..

Gracias

Paola

Carolina Belmonte

  • General
  • *
  • Mensajes: 782
    • MSN Messenger - caro_bel45@hotmail.com
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Entre Ríos
  • Nombre y apellido: Carolina Belmonte
  • Sistema: Comdoc-Kolla-Tehuelche-Toba
  • Teléfono laboral: (03442) 421539
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #4 on: Noviembre 13, 2013, 08:15:54 am »
Aprovecho este hilo para consultar lo siguiente. Estamos configurando el portal y no podemos hacerlo andar estando en distintos servidores (portal y mapuche). Me aparece el siguiente error en pantalla.

Exception Object ( [message:protected] => Error , NO Response Received [string:Exception:private] => [code:protected] => 1 [file:protected] => /var/www/autogestion/include/cWs.php [line:protected] => 150 [trace:Exception:private] => Array (
  • => Array ( [file] => /var/www/autogestion/include/cWs.php [line] => 150 [function] => request [class] => WSClient [type] => -> [args] => Array (
  • => WSMessage Object ( [str] => [action] => https://mapuche.uner.edu.ar/servicios.php/getCaptcha ) ) ) [1] => Array ( [file] => /var/www/autogestion/include/cWs.php [line] => 43 [function] => sslRequest [class] => webServiceCliente [type] => -> [args] => Array (
  • => getCaptcha ) ) [2] => Array ( [file] => /var/www/autogestion/index.php [line] => 61 [function] => __construct [class] => webServiceCliente [type] => -> [args] => Array (
  • => Array ( ) [1] => getCaptcha ) ) ) [previous:Exception:private] => )

 

Pensamos que podia ser el https de mapuche, pero tampoco es eso.
Cual puede ser el inconveniente o donde puedo configurar?

Desde ya gracias

Leonardo Ramirez

  • Moderador
  • *****
  • Mensajes: 228
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #5 on: Noviembre 13, 2013, 10:41:04 am »
Hola Carolina,

Al instalar el portal siguieron los pasos del instructivo Instalacion_Portal_del_Empleado.pdf que está en SIU Comunidad?

Si siguieron el instructivo, pudieron realizar con éxito todos los pasos de la sección "Generación y configuración de los certificados"?

Saludos
Leo

Aprovecho este hilo para consultar lo siguiente. Estamos configurando el portal y no podemos hacerlo andar estando en distintos servidores (portal y mapuche). Me aparece el siguiente error en pantalla.

Exception Object ( [message:protected] => Error , NO Response Received [string:Exception:private] => [code:protected] => 1 [file:protected] => /var/www/autogestion/include/cWs.php [line:protected] => 150 [trace:Exception:private] => Array (
  • => Array ( [file] => /var/www/autogestion/include/cWs.php [line] => 150 [function] => request [class] => WSClient [type] => -> [args] => Array (
  • => WSMessage Object ( [str] => [action] => https://mapuche.uner.edu.ar/servicios.php/getCaptcha ) ) ) [1] => Array ( [file] => /var/www/autogestion/include/cWs.php [line] => 43 [function] => sslRequest [class] => webServiceCliente [type] => -> [args] => Array (
  • => getCaptcha ) ) [2] => Array ( [file] => /var/www/autogestion/index.php [line] => 61 [function] => __construct [class] => webServiceCliente [type] => -> [args] => Array (
  • => Array ( ) [1] => getCaptcha ) ) ) [previous:Exception:private] => )

 

Pensamos que podia ser el https de mapuche, pero tampoco es eso.
Cual puede ser el inconveniente o donde puedo configurar?

Desde ya gracias

Carolina Belmonte

  • General
  • *
  • Mensajes: 782
    • MSN Messenger - caro_bel45@hotmail.com
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Entre Ríos
  • Nombre y apellido: Carolina Belmonte
  • Sistema: Comdoc-Kolla-Tehuelche-Toba
  • Teléfono laboral: (03442) 421539
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #6 on: Noviembre 13, 2013, 10:48:49 am »
Leo, los certificados no los genere yo pero aparentemente no tuvo dramas. De todas maneras probe con otros (que me paso Miguel Armentando) y tampco le gusta. El captcha no quiere levantar. Lo que le comente a Miguel fue que la unica manera con la que me anda es apuntando en el webservice.ini a un mapuceh que esta ubicado en el mismo servidor que el portal. Y en nuestra caso la idea es que esten en servidores distintos, peero no le esta gustando. Que mas puedo revisar???

Gracias


Carolina Belmonte

  • General
  • *
  • Mensajes: 782
    • MSN Messenger - caro_bel45@hotmail.com
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Entre Ríos
  • Nombre y apellido: Carolina Belmonte
  • Sistema: Comdoc-Kolla-Tehuelche-Toba
  • Teléfono laboral: (03442) 421539
Re:UNPA_Portal de Autogestion del Empleado-Configurar interaccion entre servicios
« Respuesta #7 on: Noviembre 13, 2013, 01:08:43 pm »
Leo, despues de hacer algunas pruebas los pudimos resolver. Era un problema efectivamente con el http y ademas no llegaba a resolver la ip del otrao servidor. Asi que ya esta resuelto el problema.

Gracias