Autor Tema: Problemas al instalar COMDOC II en servidor de prueba  (Leído 2318 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Víctor Costa

  • General Mapuche
  • *
  • Mensajes: 121
    • Ver Perfil
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Víctor Costa
  • Sistema: SIU - Diaguita, SIU - Toba, SIU - Guarní v3
  • Teléfono laboral: 0261 - 4135000 (int 3001) // 0261 - 4135322
Problemas al instalar COMDOC II en servidor de prueba
« on: Mayo 29, 2014, 12:43:57 pm »
Hola:

Les quería consultar por un problema que estoy teniendo para instalar COMDOC II en un servidor de testing. La idea es instalar una nueva instancia del sistema para probar la migración a COMDOC III.

El problema surge cuando copio el archivo comdocII.ear en la carpeta /usr/local/orion/applications y reinicio Orion; al ver la carpeta application-deployments/comdocII resulta que no tengo todas las carpetas de la aplicación, me falta por ejemplo la carpeta webtier.

Probé con parar Orion y eliminar la carpeta comdocII de application-deployments y volver a iniciar el servidor para que vuelva a hacer el deployment, pero no funciona.

¿Me podrían ayudar a solucionar el problema?

Muchas gracias!

Eugenia Calvo

  • Moderador Global
  • *****
  • Mensajes: 133
    • Ver Perfil
    • Email
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #1 on: Mayo 30, 2014, 02:24:04 pm »
Hola Victor,

en el archivo userlog no tira ningun mensaje?
Será algun tema de permisos? lo estas haciendo como root?

saludos
Eugenia Calvo
Sistema de Información Universitaria (SIU)
Tel +54 249 443.2304
www.siu.edu.ar

Víctor Costa

  • General Mapuche
  • *
  • Mensajes: 121
    • Ver Perfil
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Víctor Costa
  • Sistema: SIU - Diaguita, SIU - Toba, SIU - Guarní v3
  • Teléfono laboral: 0261 - 4135000 (int 3001) // 0261 - 4135322
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #2 on: Agosto 06, 2014, 10:46:06 am »
Eugenia:

Gracias por tu respuesta, realizé una instalación totalmente nueva, 0KM; para descartar problemas de permisos y de otras cosas o archivos perdidos.

Pude avanzar hasta el final de la instalación (según el manual de instalación) y ahora cambió el error. Me dice lo siguiente:

Código: [Seleccionar]
HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet.init() for servlet MainServlet threw exception
org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
java.lang.Thread.run(Thread.java:701)

root cause

java.lang.RuntimeException: java.lang.RuntimeException: javax.naming.NameNotFoundException: mappings not bound
comdocII.control.web.MainServlet.init(MainServlet.java:98)
javax.servlet.GenericServlet.init(GenericServlet.java:212)
org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
java.lang.Thread.run(Thread.java:701)

root cause

java.lang.RuntimeException: javax.naming.NameNotFoundException: mappings not bound
comdocII.util.Environment.getObjetoRemoto(Environment.java:74)
comdocII.control.web.MainServlet.init(MainServlet.java:91)
javax.servlet.GenericServlet.init(GenericServlet.java:212)
org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
java.lang.Thread.run(Thread.java:701)

root cause

javax.naming.NameNotFoundException: mappings not bound
org.jnp.server.NamingServer.getBinding(NamingServer.java:529)
org.jnp.server.NamingServer.getBinding(NamingServer.java:537)
org.jnp.server.NamingServer.getObject(NamingServer.java:543)
org.jnp.server.NamingServer.lookup(NamingServer.java:296)
org.jnp.interfaces.NamingContext.lookup(NamingContext.java:667)
org.jnp.interfaces.NamingContext.lookup(NamingContext.java:627)
javax.naming.InitialContext.lookup(InitialContext.java:409)
comdocII.util.Environment.getObjetoRemoto(Environment.java:72)
comdocII.control.web.MainServlet.init(MainServlet.java:91)
javax.servlet.GenericServlet.init(GenericServlet.java:212)
org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
java.lang.Thread.run(Thread.java:701)

note The full stack trace of the root cause is available in the JBossWeb/2.0.1.GA logs.
JBossWeb/2.0.1.GA

No encuentro que puede ser .... me podrían ayudar? A ver donde puedo mirar o que paso me faltó.

Muchas gracias!

Gustavo Pilla

  • Moderador Global
  • *****
  • Mensajes: 149
    • Ver Perfil
    • Email
  • Institución: UNAJ
  • Nombre y apellido: Gustavo Alejandro Pilla
  • Sistema: SIU-*
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #3 on: Octubre 30, 2014, 12:08:39 pm »
Lo pudiste solucionar? Estoy teniendo el mismo problema.

Víctor Costa

  • General Mapuche
  • *
  • Mensajes: 121
    • Ver Perfil
  • Institución: Universidad Nacional de Cuyo
  • Nombre y apellido: Víctor Costa
  • Sistema: SIU - Diaguita, SIU - Toba, SIU - Guarní v3
  • Teléfono laboral: 0261 - 4135000 (int 3001) // 0261 - 4135322
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #4 on: Octubre 30, 2014, 07:08:31 pm »
Gustavo
Hasta ahora no lo pude hacer andar. La verdad que estoy perdido con el tema y no se que tipo de error es el que me está dando la aplicación.

Gustavo Pilla

  • Moderador Global
  • *****
  • Mensajes: 149
    • Ver Perfil
    • Email
  • Institución: UNAJ
  • Nombre y apellido: Gustavo Alejandro Pilla
  • Sistema: SIU-*
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #5 on: Octubre 30, 2014, 07:16:22 pm »
Hola,

Estamos en la misma situación entonces, la instalación que estoy haciendo esta en un Debian Wheezy (7) con PostgreSQL 8.4 (el que trae la versión de Debian) y Java 6 de Sun (tambien la que trae Debian en sus repositorios).

Dejo los datos de la instalación por si el error es con las versiones de la distro y los paquetes del servidor, y no un tema de configuración y alguien nos puede dar una mano.

Saludos!


Eugenia Calvo

  • Moderador Global
  • *****
  • Mensajes: 133
    • Ver Perfil
    • Email
Re:Problemas al instalar COMDOC II en servidor de prueba
« Respuesta #6 on: Noviembre 05, 2014, 10:53:50 am »
Hola chicos,


el error  mappings not bound, puede ocurrir cuando no encuentra la base de datos, controlen la conexión. Si continúa el error envienme el log por mail a comdoc@siu.edu.ar, asi no llenamos el foro con detalles de log.

saludos
Eugenia
Eugenia Calvo
Sistema de Información Universitaria (SIU)
Tel +54 249 443.2304
www.siu.edu.ar