Autor Tema: Actualización de Versiones (SOLUCIONADO)  (Leído 1278 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Matias Deganis

  • Moderador Global
  • *****
  • Mensajes: 1070
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Matias Deganis
  • Sistema: SIU-Diaguita
  • Teléfono laboral: (011) 5217-3101
Actualización de Versiones (SOLUCIONADO)
« on: Noviembre 13, 2014, 10:24:16 am »
Estimados,

Seguramente la mayoría de los técnicos están al tanto, pero otros no por algunas consultas que hemos recibido. De la versión 1.14.3 pasamos directamente a la 2.0.0. Por lo tanto no hubo versiones intermedias, 1.15.x, 1.16.x, etc.

Para actualizar de la 1.14.3 a la última versión, tienen que realizar lo siguiente:

1.14.3 --> 2.0.0 --> 2.1.0 --> 2.1.2

Saludos.

Matias
« Última Modificación: Enero 30, 2015, 02:25:51 pm por mdeganis »

Juan Manuel Moreira

  • Moderador Global
  • *****
  • Mensajes: 525
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Juan Manuel Moreira
  • Sistema: Diaguita
  • Teléfono laboral: 011 5217-3101
Re:Actualización de Versiones
« Respuesta #1 on: Noviembre 20, 2014, 10:55:11 am »
Estimados....

Para adicionar a la actualización de versiones, les queríamos comentar con respecto a los perfiles funcionales, que cuando actualicen de 1.14.x a 2.x.x , miren el post http://foro.comunidad.siu.edu.ar/index.php?topic=7476.msg31855#msg31855
para poder seguir aplicando las mismas propiedades de los mismos....

Saludos.
Juan Manuel.

Lucila Baratçabal

  • Jr. Member
  • **
  • Mensajes: 82
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Centro de la Pcia. de Buenos Aires
  • Sistema: Diaguita - Mapuche
  • Teléfono laboral: 249 4422000 int 131
  • Utilizo algun sistéma del SIU: Sí
Re:Actualización de Versiones
« Respuesta #2 on: Enero 28, 2015, 10:20:20 am »
Buenos dias,
Estoy actualizando de 1.14.3 a 2.0.0 y en el paso 4: Migrar Aplicación, me da el siguiente error:

Cita
Error para migrar la versión '2.0.0'. SQLSTATE[23503]: Foreign key violation: 7 ERROR: inserción o actualización en la tabla «apex_usuario_proyecto» viola la llave foránea «apex_usu_proy_fk_grupo_acc» DETAIL: La llave (proyecto,usuario_grupo_acc)=(diaguita,compras) no está presente en la tabla «apex_usuario_grupo_acc».

Este perfil funcional "compras" al que hace referencia el error se creo en la versión 1.14.3.  y hay usuarios que lo están utilizando. Sin embargo, si me fijo en la tabla apex_usuario_grupo_acc la clave (diaguita, compras) SI existe. Donde no existe este perfil funcional es en los metadatos en: /usr/local/diaguita/instalacion/i__produccion/p__diaguita/perfiles.

Alguna idea de como lo puedo solucionar?
Gracias!

Lucila.

dzanardi

  • Sr. Member
  • ****
  • Mensajes: 338
  • Desarrollador-Diaguita
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Diego Zanardi
  • Sistema: SIU-Diaguita
Re:Actualización de Versiones
« Respuesta #3 on: Enero 28, 2015, 02:39:46 pm »
Hola lucila
Queria preguntarte acerca del ambiente y la base en donde surgue el error, debido a que si la base es de otra instalacion, hay metadatos que quedan en la misma y cuando se actualiza son necesarios y suele surgir esta clase de bugs que rompen la instalacion.

Lucila Baratçabal

  • Jr. Member
  • **
  • Mensajes: 82
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Centro de la Pcia. de Buenos Aires
  • Sistema: Diaguita - Mapuche
  • Teléfono laboral: 249 4422000 int 131
  • Utilizo algun sistéma del SIU: Sí
Re:Actualización de Versiones
« Respuesta #4 on: Enero 29, 2015, 08:59:09 am »
Hola, estoy actualizando la instalación que tenemos en producción.

dzanardi

  • Sr. Member
  • ****
  • Mensajes: 338
  • Desarrollador-Diaguita
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Diego Zanardi
  • Sistema: SIU-Diaguita
Re:Actualización de Versiones
« Respuesta #5 on: Enero 29, 2015, 03:00:56 pm »
Hola Lucila como te comente realize una prueba con una 1.14.3 con una base sin los metadatos de los perfiles funcionales a la 2.0.0 y no tuvimos incovenientes, creo que con lo comentaste en que no te creo los perfiles, y exportaste en la version 1.12.0 con el comando que es algo q no recomendamos  por favor te pido que cargues un ticket en el GDS con el directorio y la base de datos de la 1.11.1 asi procedemos a investigar cual es el problema con la generacion de los perfiles.

Lucila Baratçabal

  • Jr. Member
  • **
  • Mensajes: 82
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Centro de la Pcia. de Buenos Aires
  • Sistema: Diaguita - Mapuche
  • Teléfono laboral: 249 4422000 int 131
  • Utilizo algun sistéma del SIU: Sí
Re:Actualización de Versiones
« Respuesta #6 on: Enero 30, 2015, 02:22:25 pm »
Hola! Les cuento que finalmente pude actualizar y ya estamos en produccion en la 2.1.2!
Lo que hice fue eliminar este perfil funcional que estaba dando error y luego actualizar a la versión 2.0.0. De ahí en más pude continuar sin problemas con las actualizaciones restantes hasta llegar a la 2.1.2.
Luego de actualizar volví a crear el perfil funcional el cuestión, ya que había usuarios que lo estaban utilizando.
Muchas gracias,
Saludos,

Lucila.