Autor Tema: Instalación de Mapuche 2.3.1  (Leído 1427 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Marcelo Gómez

  • Newbie
  • *
  • Mensajes: 1
    • Ver Perfil
    • Email
  • Institución: UNSJ
  • Nombre y apellido: Marcelo Alberto Gomez
  • Sistema: Mapuche, Comdoc
  • Utilizo algun sistéma del SIU: Sí
Instalación de Mapuche 2.3.1
« on: Octubre 30, 2015, 10:58:28 am »
Estimados,  quería realizarles una consulta sobre la instalación de mapuche. Muchas gracias de antemano.

En la UNSJ tenemos actualmente una instalación de test donde los usuarios se están capacitando y actualizando datos en mapuche. Tenemos el mapuche 2.2.2 funcionando en Debian Squeeze, PHP 5.3.3, Apache 2.2.16 y postgreSQL 8.4.19.

Ahora vamos a realizar la instalación en el hardware definitivo y queríamos comenzar con mapuche 2.3.1 desde cero.

La idea es utilizar la última versión compatible de cada paquete o dependencia necesaria y el mapuche 2.3.1, tratando en lo posible de que sean los paquetes de los repositorios oficiales de la distribución (sin utilizar pinning, backports, etc).

Las opciones que hemos evaluado son las siguientes:

Ubuntu 14.04 (apache 2.4.7 , php 5.5.9, postgresql 9.3)
Debian 8 (apache 2.4.10,php 5.6.13, postgresql 9.4)
Debian 7.9 (apache 2.2.16, php 5.4.45, postgres 9.1.18)

En los talleres nos comentaron que para implementar servicios web REST necesitamos PHP 5.5 o superior. Por eso las pregunta concreta sería la siguiente:

¿Podemos instalar PHP 5.6.13 y postgresql 9.4 (Debian8) ?
¿Podemos instalar PHP 5.5.9 y posgresql 9.3 (Ubuntu 14.04) ?
¿o directamente instalo posgresql 9.1 (https://wiki.postgresql.org/wiki/Apt) en ubuntu 14.04 para cumplir en forma estricta con la versiones sugeridas en la guía de instalación? ¿si el soporte de postgresql en php dice versión 9.3.10 causará problemas?

Cualquier otro consejo que nos puedan brindar será bien recibido.

Saludos
Marcelo
UNSJ

Nicolas Dominguez Florit

  • Moderador
  • *****
  • Mensajes: 702
    • Ver Perfil
    • SIU
    • Email
  • Institución: SIU
  • Nombre y apellido: Nicolas Dominguez Florit
  • Sistema: SIU-Mapuche
Re:Instalación de Mapuche 2.3.1
« Respuesta #1 on: Octubre 30, 2015, 11:45:23 am »
La version SIU-Mapuche 2.3.1 es compatible con:
PHP 5.4 y 5.5
Apache 2.2 y 2.4
Postgresql 8.4, 9.0 y 9.1

Todo esto lo controla el instalador / actualizador.

Saludos, Nico.