Nueva versión SIU-Mapuche 1.20.1

Buenos días!

En el día de hoy fue publicada la versión 1.20.1 del sistema SIU-Mapuche. El cambio más destacado está en el proceso de generación de datos para la AFIP (SiCOSS) que debió ser adaptado de acuerdo a lo establecido por la Ley 26773 que establece que la Remuneración Imponible 9 se debe calcular sin tope y debe considerar los conceptos no remunerativos. Junto con este cambio se incluyeron varias mejoras y correcciones solicitadas, principalmente, por las instituciones que están utilizando el sistema. El listado completo y detallado de las mejoras de la versión está disponible desde cualquier versión del sistema, accediendo a la opción de menú "Ayuda > Mejoras por Versión".

Esta versión se compone sólo del paquete de instalación/actualización de la aplicación Web por lo que el módulo de Escritorio de la versión 1.20.0 sigue estando vigente como complemento del sistema. La versión puede ser descargada desde el Portal de Servicios SIU-Comunidad (http://comunidad.siu.edu.ar) accediendo al repositorio de archivos, en la ruta /SIU-Mapuche/Versiones/Última Versión.

Estamos trabajando en el análisis y la implementación de otros cambios que están introduciendo la AFIP y la ANSES por lo que vamos a ir publicando nuevas versiones a medida que dichos cambios se concreten.

Recuerden que la actualización a la última versión del sistema se puede realizar desde cualquier versión en la que se encuentren sin necesidad de pasar por versiones intermedias por lo que les recomendamos traten de mantener sus sistemas actualizados para poder aprovechar las mejoras y correcciones que se van incluyendo.

Saludos cordiales!
Equipo SIU-Mapuche

Gente, nos aparece un error cuando queremos actualizar de la 1.19.1 a la 1.20.2

Se han encontrado los siguientes errores:
SQLSTATE[42704]: Undefined object: 7 ERROR: no existe el trigger «tauditoria_dh21» para la tabla «dh21»

Como se podrá solucionar???
P/D: intente actualizar de la 1.19.1 a la 1.20.0 primero, y también nos salto ese error…

Tenes otro tabla en el esquema mapuche que tenga asignado el mismo trigger?

select tgrelid::regclass,* from pg_trigger where tgname ilike '%dh21';

De ser asi, borrale el trigger a esas tablas (ajenas al sistema) y te tendría que funcionar. Aclaración: El trigger solo debe estar en la tabla mapuche.dh21.
Saludos,
Nico.

Efectivamente teniamos una tabla bk de la dh21. Ahi estaba el problema.
Ahora si actualizamos a la 1.20.0

Gracias Nico
Saludos