Problemas en la operación Administrar requisitos de una persona

Hola, buenas tardes!

Estamos teniendo problemas en la operacion mencionada, no está guardando el estado de un documento si se lo valida.

Ejemplo de un caso: Un alumno desde Autogestión sube un requisito documental(ej: foto) y desde Gestión se lo intentan validar. Entran al requisito con el botón VER, luego se lo validan, guardan cambios y los devuelve a la pantalla principal de la operación. Pero cuando vuelven a entrar a ese registro(el alumno que subió la foto) sigue “pendiente de validación”.

Esto no pasa si se sube el requisito desde Gestión. Solamente ocurre si se intenta validar un documento que fue subido desde Autogestión.

Esa parte de la operación no fue personalizada por nosotros, luego probamos con una instalación limpia y el error persistía. Es un error de la nueva versión? Actualmente tenemos instalada la 3.20.1

Desde ya, muchas gracias.

Buenas tardes, pudieron ver esto?

Estamos teniendo ya varios casos con alumnos cuyos requisitos no podemos validar.

Hola Gaston no pudimos verlo aun.
Mientras tanto podras recuperar los logs que genera la aplicación cuando validan y guardan los cambios?
Para ver si es que se esta produciendo algun error que no se llega a ver en pantalla.

Hola Gaston
Hemos realizado pruebas en la version 3.20.1 con las mismas operaciones que mencionas y no encontramos error alguno. Vemos que la operacion visualiza bien los requisitos y los valida perfectamente, para luego verse reflejado en el estado de inscripcion a la propuesta por parte del alumno.

Cuando mencionas: " Pero cuando vuelven a entrar a ese registro(el alumno que subió la foto) sigue “pendiente de validación” esto donde lo visualizan ( en que operacion) ? desde administrar requisitos de una persona? en 3w? … no logramos visualizar esto que mencionas en ninguna de las operaciones luego de procesar y validar los requisitos en una preinscripcion a propuesta que provenga de 3w. Nos cuentan donde lo ven? y al mismo tiempo solicitamos los logs pedidos por parte de alejandro en el anterior posteo, si?

saludos

Buenas tardes!

La operación en cuestión es Administrar Requisitos de una Persona. En la imagen 1 se ve una persona cuyo requisito no está validado, clickeamos en ver, seleccionamos Aceptar el Documento Digital y guardamos. En la imagen 2 se ve que el requisito figura como Aceptado, por lo tanto presionamos guardar y nos sale el cartel que dice “Se guardó correctamente”. Pero si volvemos a entrar a este alumno, como se ve en la imagen 3, el requisito sigue pendiente de validación. Si rechaza pasa lo mismo, no guarda el estado.

En ningún momento nos arroja un error, lo cual nos parece raro. Adjunto log en el siguiente mensaje


1.png

1.png

2.png

2.png

3.png

3.png

Adjunto log. Desde ya, muchas gracias!


sistema.txt (55.8 KB)

Buenas tardes!. Pudieron revisar esto? Saludos

Agustín

Como indicó Sebastián, realizamos pruebas y no pudimos reproducir el caso.
Probaron en un ambiente de test o desarrollo y verificar si les sucede lo mismo?
¿En el log de Apache ven algo mas?

Siempre me olvido del log de apache. Ahì me daba un error y pude detectarlo. Estaba en una personalización; y por una mala organización de la personalización iba a esa clase aunque las personalizaciones estèn desactivadas. Muchas gracias.