Autor Tema: No envía mails desde la preinscripción  (Leído 785 veces)

0 Usuarios y 1 Visitante están viendo este tema.

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
No envía mails desde la preinscripción
« on: Febrero 10, 2022, 10:31:01 am »
Buenos días,
Les comento una situación rara que nos viene pasando desde que habilitamos la preinscripción 3.12
Configuramos una cuenta de gmail para el envio de los mails, la cuenta tiene habilitada la opción de Acceso de apps menos segura.
El tema es que envía los mails normalmente, de repente deja de enviar los mails y tengo que volver a entrar al archivo config.php, volver a escribir la cuenta y allí vuelve a funcionar.
No entiendo que esta pasando, si ustedes tienen alguna idea les agradezco su ayuda.
Marcela

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #1 on: Febrero 10, 2022, 12:51:50 pm »
Hola Marcela,

Es extraño que tengas que volver a cargar la cuenta en instalacion/config.php, ¿se te borra alguna configuración? ¿que parámetro dentro de SMPT tenes que volver a cargar, 'usuario'?

Te recomiendo ir a la sección de Admin de Preinscripción operación Pruebas => Probar Correo y probar cuando te pasa esto de que falla, en instalacion/config.php configura 'smtp_debug' => SMTP::DEBUG_LOWLEVEL, para que te muestre información de debug el PHPMailer.

Otra alternativa es utilizar OAUTH2 para el envió de email (si es que usan una cuenta de GMAIL), te dejo links a la documentación:
https://documentacion.siu.edu.ar/wiki/SIU-Guarani/Version3.19.0/envio-email-gmail-xoauth2

Vas a tener que configurar los siguientes parámetros:
Código: [Seleccionar]
/**
* RECOMENDADO
* Si se usa OAUTH2 se debe configurar lo siguiente
* Obtener los tokens de aquí: https://github.com/PHPMailer/PHPMailer/wiki/Using-Gmail-with-XOAUTH2
*/
'auth_type' => mail::AUTH_TYPE_XOAUTH2,
'oauth2_email' => 'preinscripcion@gmail.com',
'oauth2_client_id' => 'RANDOMCHARS-----duv1n2.apps.googleusercontent.com',
'oauth2_client_secret' => 'RANDOMCHARS-----lGyjPcRtvP',
'oauth2_refresh_token' => 'RANDOMCHARS-----DWxgOvPT003r-yFUV49TQYag7_Aod7y0',

saludos.
2

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #2 on: Febrero 10, 2022, 12:56:50 pm »
Hola Leonel,
No se borra ninguna configuración, solo vuelvo a escribir el valor en la variable en from y nada mas.
Voy a hacer esas pruebas y te aviso.
Gracias!

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #3 on: Febrero 11, 2022, 09:05:28 am »
Hola Leonel,
Te comento que hice lo que me indicaste para ver el error y el problema es que Gmail tiene un límite de envío de correos diarios y que nosotros lo estamos superando.
Por lo que leí el envío se restablece nuevamente entre 1 a 24 hs.
Te consulto porque no sé como debería configurar en preinscripción 3.12 la cuenta que tenemos de nuestra univerisidad @unsa.edu.ar, yo la configuré en la preinscripciónde G2 y nunca tuvimos problemas pero ahora en la preinscripción 3.12 no se que estoy haciendo mal.

En preinscripción de G2 tengo lo siguiente:
Código: [Seleccionar]
'smtp' =>
                array (
                    'from' => 'preinscripcion@unsa.edu.ar',
                    'from_name' => 'SIU-Preinscripcion',
                    'host' => 'ciunsa.unsa.edu.ar',
                    'seguridad' => null,
                    'auth' => null,
                    'port' => null,
                    'reply_to' => 'ingresante@gmail.com',
                    'usuario' => null,
                    'clave' => null,
),

En preinscripción 3.12 lo configuro de la siguiente manera pero no funciona (te adjunto el error que sale):
Código: [Seleccionar]
'smtp' => array(
                        'from' => 'preinscripcion@unsa.edu.ar',
                        'from_name' => 'SIU-Preinscripci�n',
                        'host' => 'ciunsa.unsa.edu.ar',
                        'seguridad' => null,
                        'auth' => null,
                        'port' => null,
                        'reply_to' => 'ingresante@gmail.com',
                        /**
                         * Debug output level.
                         * Options:
                         * * SMTP::DEBUG_OFF (`0`) No debug output, default
                         * * SMTP::DEBUG_CLIENT (`1`) Client commands
                         * * SMTP::DEBUG_SERVER (`2`) Client commands and server responses
                         * * SMTP::DEBUG_CONNECTION (`3`) As DEBUG_SERVER plus connection status
                         * * SMTP::DEBUG_LOWLEVEL (`4`) Low-level data output, all messages.
                         */
                        'smtp_debug' => SMTP::DEBUG_LOWLEVEL,

                        /**
                         * RECOMENDADO
                         * Si se usa OAUTH2 se debe configurar lo siguiente
                         * Obtener los tokens de aqu�: https://github.com/PHPMailer/PHPMailer/wiki/Using-Gmail-with-XOAUTH2
                         */
                        //'auth_type' => mail::AUTH_TYPE_XOAUTH2,
                        //'oauth2_email' => 'preinscripcion@gmail.com',
            //'oauth2_client_id' => 'RANDOMCHARS-----duv1n2.apps.googleusercontent.com',
            //'oauth2_client_secret' => 'RANDOMCHARS-----lGyjPcRtvP',
            //'oauth2_refresh_token' => 'RANDOMCHARS-----DWxgOvPT003r-yFUV49TQYag7_Aod7y0',

                        /**
                         * NO RECOMENDADO: Se debe dar "Acceso de apps menos seguras" en Gmail
                         * Si se usa autenticaci�n simple configurar 'usuario' y 'clave'
                         */
                        //'auth_type' => mail::AUTH_TYPE_USER_PASS,
                        //'usuario' => null,
                        //'clave' => null,

Espero puedas orientarme.
Saludos!

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #4 on: Febrero 11, 2022, 10:01:47 am »
Hola Marcela,

Deberías configurarlo de la siguiente manera:

Código: [Seleccionar]
//--------------------------------------------------------------------------
//---- Servidor de correo --------------------------------------------------
//--------------------------------------------------------------------------

/**
* Se provee un ejemplo de configuración del correo usando el servidor de GMail
*/
'smtp' => [
'from' => 'cuenta@gmail.com',
'from_name' => 'SIU-Preinscripción',
'host' => 'smtp.gmail.com',
'seguridad' => mail::SSL,
'auth' => true,
'port' => 465,
'reply_to' => 'reply_to@gmail.com',
/**
* Debug output level.
* Options:
* * SMTP::DEBUG_OFF (`0`) No debug output, default
* * SMTP::DEBUG_CLIENT (`1`) Client commands
* * SMTP::DEBUG_SERVER (`2`) Client commands and server responses
* * SMTP::DEBUG_CONNECTION (`3`) As DEBUG_SERVER plus connection status
* * SMTP::DEBUG_LOWLEVEL (`4`) Low-level data output, all messages.
*/
'smtp_debug' => SMTP::DEBUG_OFF,

/**
* NO RECOMENDADO: Se debe dar "Acceso de apps menos seguras" en Gmail
* Si se usa autenticación simple configurar 'usuario' y 'clave'
*/
'auth_type' => mail::AUTH_TYPE_USER_PASS,
'usuario' => 'cuenta@gmail.com',
'clave' => '**********',

],

No cambia mucho entre Preinscripción 2 y Preinscripción 3.

Veo que en los logs que me mandantes muestra lo siguiente:
Código: [Seleccionar]
2022-02-11 11:55:34 Connection failed. Error #2: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed [/proyectos/preinscripcion/vendor/phpmailer/phpmailer/src/SMTP.php line 454]
SMTP Error: Could not connect to SMTP host.

Buscando el error encontré lo siguiente:
https://github.com/PHPMailer/PHPMailer/issues/2061
https://stackoverflow.com/questions/30556773/how-to-fix-stream-socket-enable-crypto-ssl-operation-failed-with-code-1
https://www.lawebdelprogramador.com/foros/PHP/1511206-solucionado-stream_socket_enable_crypto-SSL-operation-failed-with-code-1.html

En instalacion/config.php podes descomentar la parte que dice:

Código: [Seleccionar]
// Decidir si se verifican los certificados en una conexión SSL
// Ver: https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#php-56-certificate-verification-failure
'ssl' => [
'verify_peer' => false,
'verify_peer_name' => false,
'allow_self_signed' => true
]

No es lo mas recomendado pero quizás sirva.

Cita
Te comento que hice lo que me indicaste para ver el error y el problema es que Gmail tiene un límite de envío de correos diarios y que nosotros lo estamos superando.
Si, Gmail tiene un limite o quota como le llaman (https://support.google.com/a/answer/166852?hl=en).

Igualmente en los logs veo que usas el host ciunsa.unsa.edu.ar en el puerto 25, quizás te convenga usar host smtp.gmail.com en puerto 465 (ssl) o 587 (tls):

Código: [Seleccionar]
'host' => 'smtp.gmail.com',
'seguridad' => mail::SSL,
'auth' => true,
'port' => 465,


Código: [Seleccionar]
'host' => 'smtp.gmail.com',
'seguridad' => mail::TLS,
'auth' => true,
'port' => 587,

saludos.
2
« Última Modificación: Febrero 11, 2022, 10:08:27 am por Leonel Leonardis »

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #5 on: Febrero 11, 2022, 11:52:04 am »
Hola Leonel,
Lo que yo quiero configurar es con una cuenta @unsa.edu.ar por eso estaba utilizando el host ciunsa.unsa.edu.ar.
Probé hacer lo que me indicas y no envía los mails.
En preinscripción G2 lo tenía configurado de la siguiente manera:
Código: [Seleccionar]
'smtp' =>
                array (
                    'from' => 'preinscripcion@unsa.edu.ar',
                    'from_name' => 'SIU-Preinscripcion',
                    'host' => 'ciunsa.unsa.edu.ar',
                    'seguridad' => null,
                    'auth' => null,
                    'port' => null,
                    'reply_to' => 'ingresante@gmail.com',
                    'usuario' => null,
                    'clave' => null,
Lo configuro igual y no pasa nada, en preinscripción 3.12 lo único que no tengo son las entradas usuario y clave.

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #6 on: Febrero 11, 2022, 02:33:45 pm »
Leonel, te comento lo siguiente,
Me dicen los técnicos que hace un tiempo atrás desde el SIU les solicitaron una cuenta de la UNSA para que ellos lo configuren en el sistema Quechua para el envío de mensajes, dicha cuenta debía tener ciertas condiciones de seguridad y que el administrador de la Universidad le dijo que el servidor de correos de la UNSa no cuenta con esa configuración, así que no se pudo configurar.
Tenés idea si algo de eso puede estar pasando en la preinscripción?
Saludos!

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #7 on: Febrero 11, 2022, 02:53:08 pm »
Hola Marcela,

¿las cuentas @unsa.edu.ar son de gmail? Nosotros tenemos las cuentas @siu.edu.ar que son cuentas de gmail.

Esos valores null que me pones en el ejemplo, ¿están así en null o pones null en reemplazo al valor real?

¿Podes pasarme como tenes las configuración SMTP sin usuario y clave?

¿te funciona bien el envío de emails en Guaraní Gestión y Autogestión?

Cita
Me dicen los técnicos que hace un tiempo atrás desde el SIU les solicitaron una cuenta de la UNSA para que ellos lo configuren en el sistema Quechua para el envío de mensajes, dicha cuenta debía tener ciertas condiciones de seguridad y que el administrador de la Universidad le dijo que el servidor de correos de la UNSa no cuenta con esa configuración, así que no se pudo configurar.
Tenés idea si algo de eso puede estar pasando en la preinscripción?
Por lo que veo en los logs estas usando el host ciunsa.unsa.edu.ar con el puerto 25.

Referencia:
https://netcorecloud.com/tutorials/phpmailer-smtp-error-could-not-connect-to-smtp-host/
https://stackoverflow.com/questions/52552986/how-can-i-send-an-email-via-phpmailer-without-ssl-port-25

saludos.
4
« Última Modificación: Febrero 11, 2022, 03:00:42 pm por Leonel Leonardis »

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #8 on: Febrero 14, 2022, 10:24:41 am »
Hola Leonel,
Las cuentas @unsa.edu.ar no son de gmail, en la universidad hay un servidor de correo propio.
Los valores en null se los pongo porque así van, no es en reemplazo de ningún valor, así lo tenía configurado en la preinscripción de G2.
En Guaraní Gestión utilizamos una cuenta @gmail y si funciona porque el envío de mails no supera la quota de gmail, autogestión se habilitó hoy y veremos que pasa pero también tiene una cuenta @gmail.
Utilizo el host ciunsa.unsa.edu.ar porque ese es el servidor de correo de la unsa.
Te paso como lo configuro pero no funciona..
Código: [Seleccionar]
'smtp' => array(
                        'from' => 'preinscripcion@unsa.edu.ar',
                        'from_name' => 'SIU-Preinscripci�n',
                        'host' => 'ciunsa.unsa.edu.ar',
                        'seguridad' => null,
                        'auth' => null,
                        'port' => null,
                        'reply_to' => 'ingresante@gmail.com',
                        /**
                         * Debug output level.
                         * Options:
                         * * SMTP::DEBUG_OFF (`0`) No debug output, default
                         * * SMTP::DEBUG_CLIENT (`1`) Client commands
                         * * SMTP::DEBUG_SERVER (`2`) Client commands and server responses
                         * * SMTP::DEBUG_CONNECTION (`3`) As DEBUG_SERVER plus connection status
                         * * SMTP::DEBUG_LOWLEVEL (`4`) Low-level data output, all messages.
                         */
                        'smtp_debug' => SMTP::DEBUG_LOWLEVEL,

                        /**
                         * RECOMENDADO
                         * Si se usa OAUTH2 se debe configurar lo siguiente
                         * Obtener los tokens de aqu�: https://github.com/PHPMailer/PHPMailer/wiki/Using-Gmail-with-XOAUTH2
                         */
                        //'auth_type' => mail::AUTH_TYPE_XOAUTH2,
                        //'oauth2_email' => 'preinscripcion@gmail.com',
            //'oauth2_client_id' => 'RANDOMCHARS-----duv1n2.apps.googleusercontent.com',
            //'oauth2_client_secret' => 'RANDOMCHARS-----lGyjPcRtvP',
            //'oauth2_refresh_token' => 'RANDOMCHARS-----DWxgOvPT003r-yFUV49TQYag7_Aod7y0',

                        /**
                         * NO RECOMENDADO: Se debe dar "Acceso de apps menos seguras" en Gmail
                         * Si se usa autenticaci�n simple configurar 'usuario' y 'clave'
                         */
                        //'auth_type' => mail::AUTH_TYPE_USER_PASS,
                        //'usuario' => null,
                        //'clave' => null,

El único problema con gmail es la quota, solo por eso quería utilizar la cuenta @unsa.edu.ar
Saludos!

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #9 on: Febrero 14, 2022, 10:47:33 am »
Hola Marcela,

Hay valores que están en null y debería tener algún valor.

Nosotros siempre utilizamos Gmail para el envío de emails con SMTP, deberías ver los ejemplos que da PHPMailer para tu caso: https://github.com/PHPMailer/PHPMailer/tree/v6.1.8/examples

Quizás puedas probar este ejemplo: https://github.com/PHPMailer/PHPMailer/blob/v6.1.8/examples/smtp_no_auth.phps

O este otro código para chequear porque no funciona: https://github.com/PHPMailer/PHPMailer/blob/v6.1.8/examples/smtp_check.phps

¿que ocurre si configuras de la siguiente manera?
Código: [Seleccionar]
'smtp' => array(
                        'from' => 'preinscripcion@unsa.edu.ar',
                        'from_name' => 'SIU-Preinscripci�n',
                        'host' => 'ciunsa.unsa.edu.ar',
                        'seguridad' => '',
                        'auth' => false,
                        'port' => 25,
                        'reply_to' => 'ingresante@gmail.com',
                        /**
                         * Debug output level.
                         * Options:
                         * * SMTP::DEBUG_OFF (`0`) No debug output, default
                         * * SMTP::DEBUG_CLIENT (`1`) Client commands
                         * * SMTP::DEBUG_SERVER (`2`) Client commands and server responses
                         * * SMTP::DEBUG_CONNECTION (`3`) As DEBUG_SERVER plus connection status
                         * * SMTP::DEBUG_LOWLEVEL (`4`) Low-level data output, all messages.
                         */
                        'smtp_debug' => SMTP::DEBUG_LOWLEVEL,

                        /**
                         * RECOMENDADO
                         * Si se usa OAUTH2 se debe configurar lo siguiente
                         * Obtener los tokens de aqu�: https://github.com/PHPMailer/PHPMailer/wiki/Using-Gmail-with-XOAUTH2
                         */
                        //'auth_type' => mail::AUTH_TYPE_XOAUTH2,
                        //'oauth2_email' => 'preinscripcion@gmail.com',
            //'oauth2_client_id' => 'RANDOMCHARS-----duv1n2.apps.googleusercontent.com',
            //'oauth2_client_secret' => 'RANDOMCHARS-----lGyjPcRtvP',
            //'oauth2_refresh_token' => 'RANDOMCHARS-----DWxgOvPT003r-yFUV49TQYag7_Aod7y0',

                        /**
                         * NO RECOMENDADO: Se debe dar "Acceso de apps menos seguras" en Gmail
                         * Si se usa autenticaci�n simple configurar 'usuario' y 'clave'
                         */
                        //'auth_type' => mail::AUTH_TYPE_USER_PASS,
                        //'usuario' => null,
                        //'clave' => null,

saludos.
2

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #10 on: Febrero 14, 2022, 07:20:56 pm »
Hola Leonel,
Probé con la configuración que me indicaste y tampoco funciona.
Voy a leer los links que me pasaste y te aviso.
Saludos!

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #11 on: Febrero 15, 2022, 09:45:46 am »
Hola Marcela,

Proba con la siguiente configuración:

Código: [Seleccionar]
'smtp' => array(
                        'from' => 'preinscripcion@unsa.edu.ar',
                        'from_name' => 'SIU-Preinscripción',
                        'host' => 'ciunsa.unsa.edu.ar',
                        'seguridad' => '',
                        'auth' => false,
                        'port' => 25,
                        'reply_to' => 'ingresante@gmail.com',
                        /**
                         * Debug output level.
                         * Options:
                         * * SMTP::DEBUG_OFF (`0`) No debug output, default
                         * * SMTP::DEBUG_CLIENT (`1`) Client commands
                         * * SMTP::DEBUG_SERVER (`2`) Client commands and server responses
                         * * SMTP::DEBUG_CONNECTION (`3`) As DEBUG_SERVER plus connection status
                         * * SMTP::DEBUG_LOWLEVEL (`4`) Low-level data output, all messages.
                         */
                        'smtp_debug' => SMTP::DEBUG_LOWLEVEL,

                        /**
                         * RECOMENDADO
                         * Si se usa OAUTH2 se debe configurar lo siguiente
                         * Obtener los tokens de aquí: https://github.com/PHPMailer/PHPMailer/wiki/Using-Gmail-with-XOAUTH2
                         */
                        //'auth_type' => mail::AUTH_TYPE_XOAUTH2,
                        //'oauth2_email' => 'preinscripcion@gmail.com',
            //'oauth2_client_id' => 'RANDOMCHARS-----duv1n2.apps.googleusercontent.com',
            //'oauth2_client_secret' => 'RANDOMCHARS-----lGyjPcRtvP',
            //'oauth2_refresh_token' => 'RANDOMCHARS-----DWxgOvPT003r-yFUV49TQYag7_Aod7y0',

                        /**
                         * NO RECOMENDADO: Se debe dar "Acceso de apps menos seguras" en Gmail
                         * Si se usa autenticación simple configurar 'usuario' y 'clave'
                         */
                        //'auth_type' => mail::AUTH_TYPE_USER_PASS,
                        //'usuario' => null,
                        //'clave' => null,

/*
* Decido si verifico los certificados en una conexión SSL
* Ver: https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#php-56-certificate-verification-failure
*/
'ssl' => [
'verify_peer' => false,
'verify_peer_name' => false,
'allow_self_signed' => true
]

Se agrega lo siguiente:
Código: [Seleccionar]
/*
* Decido si verifico los certificados en una conexión SSL
* Ver: https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#php-56-certificate-verification-failure
*/
'ssl' => [
'verify_peer' => false,
'verify_peer_name' => false,
'allow_self_signed' => true
]

¿su servidor SMTP no tiene autenticación, no usa usuario y clave?

Revisa la respuesta 4 de este mismo foro.

Luego volve a hacer las pruebas que te pedí en la respuesta 1 y me volves a pasar los logs.

saludos.
2
« Última Modificación: Febrero 15, 2022, 09:52:05 am por Leonel Leonardis »

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #12 on: Febrero 16, 2022, 09:55:01 am »
Hola Leonel,
Perdón que conteste recién pero estaba con otras cosas, ya hago las pruebas y te adjunto el log.
Saludos!

lrodas

  • General Guarani
  • *
  • Mensajes: 402
    • Ver Perfil
  • Institución: Universidad Nacional de Salta
  • Nombre y apellido: Marcela Rodas
  • Sistema: SIU-Guaraní
Re:No envía mails desde la preinscripción
« Respuesta #13 on: Febrero 18, 2022, 12:03:28 pm »
Hola Leonel,
Hice los últimos cambios que me indicaste y sigue sin funcionar, te adjunto el log.
Te consulto, sabes si las otras universidades utilizan sólo cuentas de Gmail y como hacen con la quota?
Saludos!

Leonel Leonardis

  • Moderador Global
  • *****
  • Mensajes: 2485
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Leonel Leonardis
  • Sistema: SIU-Guaraní
  • Utilizo algun sistéma del SIU: Sí
Re:No envía mails desde la preinscripción
« Respuesta #14 on: Febrero 18, 2022, 04:18:00 pm »
Hola Marcela,

Cita
Te consulto, sabes si las otras universidades utilizan sólo cuentas de Gmail y como hacen con la quota?
Según el soporte que he dado la mayoría usa Gmail. Lo de la quota no lo se, te lo averiguo.

Cita
Hice los últimos cambios que me indicaste y sigue sin funcionar, te adjunto el log.
Sigo viendo lo siguiente en el log:
Código: [Seleccionar]
2022-02-18 14:57:08 Connection failed. Error #2: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed [/proyectos/preinscripcion/vendor/phpmailer/phpmailer/src/SMTP.php line 454]
SMTP Error: Could not connect to SMTP host.

Para mi el problema es que no es SMPT sino MAIL, probemos la solución que proponen acá:

En la función enviar de vendor/siu/chulupi-framework/src/SIU/Chulupi/util/mail.php cambia $mail->IsSMTP(); por $mail->isMail();

Referencia:
https://www.codegrepper.com/code-examples/whatever/stream_socket_enable_crypto%28%29%3A+SSL+operation+failed+with+code+1.+OpenSSL+Error+messages%3A%5Cnerror%3A1416F086%3ASSL+routines%3Atls_process_server_certificate%3Acertificate+verify+failed

saludos.
2
« Última Modificación: Febrero 18, 2022, 04:21:26 pm por Leonel Leonardis »